Mastering Physics Maintenance
Maintenance
2023-11-18T14:00:24.9730000Z
Mastering Physics Maintenance
Status: Closed
Start:
2023-11-18T02:00:00.0000000Z
End:
2023-11-18T14:00:24.9730000Z
Duration: 12 hours
Affected Components:
Higher Education Courseware
Mastering
Update
2023-11-18T02:00:00.0000000Z
2023-11-18T02:00:00.0000000Z
During this time, we will be performing maintenance that will impact Mastering Physics; this courseware will be unavailable. All other Mastering courses will be available.
Resolved
2023-11-18T14:00:24.9730000Z
2023-11-18T14:00:24.9730000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.