HED Scheduled Maintenance
Maintenance
2023-11-25T14:00:07.0400000Z
HED Scheduled Maintenance
Status: Closed
Start:
2023-11-25T06:00:00.0000000Z
End:
2023-11-25T14:00:07.0400000Z
Duration: 8 hours
Affected Components:
Pearson +
Higher Education Courseware
Pearson +
Learning Catalytics
Mastering
MyLab
Pearson Interactive Labs
Revel
StatCrunch
Update
2023-11-25T06:00:00.0000000Z
2023-11-25T06:00:00.0000000Z
We will be performing maintenance. During this time, access will be unavailable.
Resolved
2023-11-25T14:00:07.0400000Z
2023-11-25T14:00:07.0400000Z
We have completed scheduled maintenance. Thanks for your patience.