MyLabs Maintenance
Maintenance
2023-11-18T14:00:29.1330000Z
MyLabs Maintenance
Status: Closed
Start:
2023-11-18T06:00:00.0000000Z
End:
2023-11-18T14:00:29.1330000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
MyLab
Update
2023-11-18T06:00:00.0000000Z
2023-11-18T06:00:00.0000000Z
We will be performing maintenance that will impact MyLab courseware. During this time, courses will be unavailable.
Resolved
2023-11-18T14:00:29.1330000Z
2023-11-18T14:00:29.1330000Z
We have completed scheduled maintenance. Thanks for your patience.