Maintenance

Maintenance

Maintenance

Status: Closed
Start:
End:
Duration: 11 hours
Affected Components:
Higher Education Courseware Mastering
Update

We will be performing maintenance on some Mastering courses. During this time, access will be unavailable for the following Mastering disciplines: A&P, Biology, Engineering, Environmental Science, Geography, Geology, and Meteorology. 


Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.